On May 24, 2011, at 01:59 , Alex V. wrote:

> Hello Ryan, thank you for your detailed answer. I still have a lot of
> problems, so I will explain my approach step by step:
> 
> First, I installed the lastest version of Ruby (1.9.2-p180) by
> downloading and compiling the source code on my Ubuntu virtual machine.
> This install includes Gem, when I type "gem -v" I get "1.3.7". So I
> tried to use this gem version to install metric_fu, and I got :
> 
> "
> root@Alexis-VBox-Ubuntu:~# gem install metric_fu --http-proxy ...
> ERROR:  Loading command: install (LoadError)
>    no such file to load -- zlib

You should have stopped at this point. Googling that error message would have helped a lot and pointed out that you need zlib (and probably other stuff). Since you're on ubuntu, I'd highly recommend using rvm to manage your ruby install as a whole. There's great doco for it, and you'll specifically want to focus on:

http://beginrescueend.com/packages/