I use a fresh installation of ruby 1.9.2p180 to make some tests with
web-frameworks on a windows machine.

Most installation of libraries went through without problems.

Except: json and thin (the eventmachine part)

"
Fetching: eventmachine-0.12.10.gem (100%)
ERROR:  Error installing thin:
        The 'eventmachine' native gem requires installed build tools.
"

for JSON there is a json_pure replacement (gem install json_pure).

is there any replacement for "eventmachine"?

Requirement:

installation without any (either manual or automatic) compilation
steps.

.

--
(please refrain from off-topic and off-context comments and focus on
the technical essence)
http://lazaridis.com