On May 13, 2011, at 16:50 , james b. wrote:

> Thanks for the replies
>=20
> I am currently using
> require "gem_name/server"
>=20
> I tried the other two suggestions but still no success

The last part you need to know is that 1.9 dropped '.' from the default =
load path. that's why I say put it in lib and make sure lib is in your =
path on BOTH 1.8 and 1.9.=20

> gem_name.rb is in the lib directory already and i'm not (gasp) using =
any
> tests. The problem occurs when i install the gem using rake install
> provided to me by bundler. I hope that it will work if you install it
> through rubygems but i somehow doubt that.
>=20
> I know i really should have tests so i guess now is as good a time as
> ever to start so if you can suggest a test framework to use that would
> be great.

I use minitest for nearly everything. Ships with 1.9. I use Hoe with my =
projects so it's all integrated and happy.=