The command  "gem list -rd  a"   generates the following error:


C:\gemlist>gem list -rd a

*** REMOTE GEMS ***

ERROR:  While executing gem ... (ArgumentError)
    undefined class/module YAML::Syck::DefaultKey

C:\Users\spanton\gemlist>gem update --system
Latest version currently installed. Aborting.

-------------------------------------------------------------------
I running the following software:

Windows 7
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]
gem  1.8.1

Any suggetions or workaround?

Thanks,
John