You have to then reinstall 1.9.2 after installing openssl-devel for it to
build a ruby with it. ;)
Also, /usr/local/lib/ruby/gems/1.9.1/gems/mechanize-1.0.0/lib/mechanize.rb:2:in
`<top (required)>' suggests that you're still using your system Ruby, rather
than the rvm one, as it's usuall ~/.rvm/...