Hi Steve,

Thank you for your suggestion. I already tried gen install  mechanize. I
just did it again to post the outcome:

First:
[root@oc7871667644 ~]# *ruby -v*
*ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]*

I was missing the *libxml2*, as you can see from this msg:

[root@oc7871667644 ~]# gem install mechanize
Building native extensions.  This could take a while...
ERROR:  Error installing mechanize:
    ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb
checking for libxml/parser.h... no
-----
*libxml2 is missing.*  please visit
http://nokogiri.org/tutorials/installing_nokogiri.html for help with
installing dependencies.

I went to the page listed above and followed the procedure listed,
installing the require packages.
I then proceded to install *mechanize* and it worked.

*NOW I HAVE A NEW PROBLEM, WITH OPENSSL:*

I tried installing *openssl via: rvm package install openssl This
installation worked. *However, the shoes install still complaining that
openssl is not there.* openssl* is found at: */usr/local/rvm/usr/bin/openssl
*:
*OpenSSL> version
OpenSSL 0.9.8n 24 Mar 2010
OpenSSL>*

THE FOLLOWING IS THE OUTPUT WHEN I TRY T BUILD SHOES:

Initialized empty Git repository in /usr/local/shoes/.git/
remote: Counting objects: 9741, done.
remote: Compressing objects: 100% (3089/3089), done.
remote: Total 9741 (delta 6630), reused 9595 (delta 6519)
Receiving objects: 100% (9741/9741), 4.46 MiB | 42 KiB/s, done.
Resolving deltas: 100% (6630/6630), done.
Loaded plugins: ibm-cds-plugin, ibm-repository, refresh-packagekit
Setting up Install Process
Package giflib-devel-4.1.6-3.1.el6.x86_64 already installed and latest
version
Package cairo-devel-1.8.8-3.1.el6.x86_64 already installed and latest
version
No package libpixman-devel available.
Package pango-devel-1.28.1-3.el6_0.5.x86_64 already installed and latest
version
Package libjpeg-devel-6b-46.el6.x86_64 already installed and latest version
Package gtk2-devel-2.18.9-4.el6.x86_64 already installed and latest version
Package libcurl-devel-7.19.7-16.el6.x86_64 already installed and latest
version
Package ruby-devel-1.8.7.299-5.el6_0.1.x86_64 already installed and latest
version
Nothing to do
(in /usr/local/shoes)

*rake aborted!
no such file to load -- openssl*
<internal:lib/rubygems/custom_require>:29:in `require'
<internal:lib/rubygems/custom_require>:29:in `require'
/usr/local/lib/ruby/1.9.1/net/https.rb:92:in `<top (required)>'
<internal:lib/rubygems/custom_require>:29:in `require'
<internal:lib/rubygems/custom_require>:29:in `require'
/usr/local/lib/ruby/gems/1.9.1/gems/mechanize-1.0.0/lib/mechanize.rb:2:in
`<top (required)>'
<internal:lib/rubygems/custom_require>:33:in `require'
<internal:lib/rubygems/custom_require>:33:in `rescue in require'
<internal:lib/rubygems/custom_require>:29:in `require'
/usr/local/shoes/Rakefile:291:in `<top (required)>'
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in `load'
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in `raw_load_rakefile'
/usr/local/lib/ruby/1.9.1/rake.rb:2007:in `block in load_rakefile'
/usr/local/lib/ruby/1.9.1/rake.rb:2058:in `standard_exception_handling'
/usr/local/lib/ruby/1.9.1/rake.rb:2006:in `load_rakefile'
/usr/local/lib/ruby/1.9.1/rake.rb:1991:in `run'
/usr/local/bin/rake:31:in `<main>'

I also checked the *openssl* that came with RHEL 6:
[root@oc7871667644 openssl]#* rpm -qa | grep -i openssl*
openssl-1.0.0-4.el6_0.2.x86_64
openssl098e-0.9.8e-17.el6.x86_64
openssl-1.0.0-4.el6_0.2.i686

Basically, I am totally lost.

Thank you for your help.

On Tue, May 3, 2011 at 6:04 PM, Steve Klabnik <steve / steveklabnik.com>wrote:

> Hm, the last person that got that error said they were using 1.8, but
> you're
> obviously using 1.9.1.
>
> Can you try running 'gem install mechanize' and then doing it again,
> please?
> If this is needed, I"ll add it to the instructions.
>



-- 
Ruby Student