From: "Patrick Lynch" <kmandpjlynch / verizon.net>
Subject: Re: Tk : non blocking Tk.mainloop
Date: Tue, 3 May 2011 22:52:45 +0900
Message-ID: <DBA039E5453C4849A525D5FF801EB84A / UserPC>
> I'm working with an iMac Snow Leopard...and Ruby 1.8.7...
> I have TK installed and can access it from the Bash command line - but it is 
> not known to my Ruby, eg, require 'Tk' returns and error message in irb...
> I probably should have started a separate link...but I thought I stand a 
> good chance of getting some help here...

I'm not a Mac user. So, I don't have a proper answer.
However...
I heard that Snow Leopard stopped official support of Ruby/Tk.
It means that you must compile full or tcltklib extension of Ruby,
if you want use Ruby/Tk.
When compile, please pay attention to binary type; whether 32bit or
64bit. Ruby/Tk should work on each of 32bit and 64bit, if Ruby and
Tcl/Tk libraries are made as same binary type.
-- 
Hidetoshi NAGAI (nagai / ai.kyutech.ac.jp)
Department of Artificial Intelligence, Kyushu Institute of Technology