Hm, the last person that got that error said they were using 1.8, but you're
obviously using 1.9.1.

Can you try running 'gem install mechanize' and then doing it again, please?
If this is needed, I"ll add it to the instructions.