--bcaec520eee56630ad04a264d39d
Content-Type: text/plain; charset=ISO-8859-1

Actually, I did try to build my own shoes using the instructions:

git clone git://github.com/shoes/shoes.git ${SHOES_DIR}
cd ${SHOES_DIR}
sudo yum install -y giflib-devel cairo-devel libpixman-devel
pango-devel libjpeg-devel gtk2-devel libcurl-devel ruby-devel
rake


When I run this simple script, it fails with the following messages
displayed:

Initialized empty Git repository in /usr/local/shoes/.git/
remote: Counting objects: 9741, done.
remote: Compressing objects: 100% (3089/3089), done.
remote: Total 9741 (delta 6630), reused 9595 (delta 6519)
Receiving objects: 100% (9741/9741), 4.46 MiB | 41 KiB/s, done.
Resolving deltas: 100% (6630/6630), done.
Loaded plugins: ibm-cds-plugin, ibm-repository, refresh-packagekit
Setting up Install Process
Package giflib-devel-4.1.6-3.1.el6.x86_64 already installed and latest
version
Package cairo-devel-1.8.8-3.1.el6.x86_64 already installed and latest
version
*No package libpixman-devel available.*
Package pango-devel-1.28.1-3.el6_0.5.x86_64 already installed and latest
version
Package libjpeg-devel-6b-46.el6.x86_64 already installed and latest version
Package gtk2-devel-2.18.9-4.el6.x86_64 already installed and latest version
Package libcurl-devel-7.19.7-16.el6.x86_64 already installed and latest
version
Package ruby-devel-1.8.7.299-5.el6_0.1.x86_64 already installed and latest
version
Nothing to do
(in /usr/local/shoes)
*rake aborted!
no such file to load -- mechanize*
<internal:lib/rubygems/custom_require>:29:in `require'
<internal:lib/rubygems/custom_require>:29:in `require'
/usr/local/shoes/Rakefile:291:in `<top (required)>'
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in `load'
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in `raw_load_rakefile'
/usr/local/lib/ruby/1.9.1/rake.rb:2007:in `block in load_rakefile'
/usr/local/lib/ruby/1.9.1/rake.rb:2058:in `standard_exception_handling'
/usr/local/lib/ruby/1.9.1/rake.rb:2006:in `load_rakefile'
/usr/local/lib/ruby/1.9.1/rake.rb:1991:in `run'
/usr/local/bin/rake:31:in `<main>'

I think that I am missing *mechanize*. I tried to install at least a dozen
times in different ways but could not.

So at this point I am totally lost!

Thank you

On Tue, May 3, 2011 at 3:06 PM, Ruby Student <ruby.student / gmail.com> wrote:

> Well friend, I can hardly put on a shoe. I am sure I can't build one!
>
> Do you happen to have a link to the instructions on how to build a shoe?
>
> I don't know the real reason not to uninstall the current latest version
> and
> install 0.9.8.
>
> Thank you
>
>
> On Tue, May 3, 2011 at 2:39 PM, Steve Klabnik <steve / steveklabnik.com
> >wrote:
>
> > Two things:
> >
> > One: libssl.so.0.9.8 means 'version 0.9.8,' and you have 1.0.0 installed,
> > so
> > of course there's a mismatch. ;)
> >
> > Two: as you'll note, it says that that won't always work. ;) If getting
> the
> > older libssl installed doesn't, then you should try building a Shoes.
> >
>
>
>
> --
> Ruby Student
>



-- 
Ruby Student

--bcaec520eee56630ad04a264d39d--