Two things:

One: libssl.so.0.9.8 means 'version 0.9.8,' and you have 1.0.0 installed, so
of course there's a mismatch. ;)

Two: as you'll note, it says that that won't always work. ;) If getting the
older libssl installed doesn't, then you should try building a Shoes.