On Apr 28, 2011, at 1:54 AM, Brian Candler wrote:

> What happens in your irb session if you type:
> 
> require "renren_api/authentication"
> 
> ?
> 
> -- 
> Posted via http://www.ruby-forum.com/.
> 


I receive a LoadError.

ruby-1.9.2-head :001 > require "renren_api/authentication"
LoadError: no such file to load -- renren_api/authentication
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from (irb):1
	from /Users/siegfried/.rvm/rubies/ruby-1.9.2-head/bin/irb:16:in `<main>'


Best regards,
Zhi-Qiang Lei
zhiqiang.lei / gmail.com