On Wed, Apr 20, 2011 at 8:55 AM, Martin Hansen <mail / maasha.dk> wrote:
> $ ruby -d j.rb ->
>
> http://pastie.org/1815275

"Exception `ArgumentError' at
/Users/maasha/maasha_install/lib/ruby/1.9.1/x86_64-darwin10.6.0/digest/md5.=
bundle
- undefined class/module Digest::Base"

>> Also, can you just try "require 'digest/md5'" in irb?
>
> irb(main):001:0> require 'digest/md5'
> ArgumentError: undefined class/module Digest::Base
> =A0 =A0 =A0 =A0from <internal:lib/rubygems/custom_require>:29:in `require=
'
> =A0 =A0 =A0 =A0from <internal:lib/rubygems/custom_require>:29:in `require=
'
> =A0 =A0 =A0 =A0from (irb):1
> =A0 =A0 =A0 =A0from /Users/maasha/maasha_install/bin/irb:12:in `<main>'

Okay, so the issue is in your ruby not RubyInline.

I updated my machine to 10.6.7 (uname: 10.7.0 :-) and my previously
compiled 1.9.2 still works correctly.  Can you try to install a fresh
build in another prefix (by hand, RVM, or homebrew) and see if the
same behavior is still present?

Thanks.