Martin Hansen <mail / maasha.dk> wrote:
> > Your Ruby was compiled under 10.7 or 10.6?
>
> I keep a log of the ruby compile. It looks like it was build under
> 10.6.0. The Mac OS here is 10.6.7 (there is no 10.7 out yet).

Oh, okay.  I wanted to check since your uname above said "10.7.0".

> Is there a better place for this "bug report" than this thread?

Ruby Issue Tracking System: http://redmine.ruby-lang.org/

Can you run your test script with "ruby -d"?