Lszl Fldes wrote in post #990509:
> I want to use Ruby 1.9.1 (Ubuntu 10.10) with Tk8.5 Tile, but this samle> code:
> [...]
> I'm not a source code compiler type, I
> installed everything from aptitude (Ruby 1.9.1, Tk8.4, Tk8.5, Tcl8.4,
> Tcl8.5)

Hi!

I'm using Ubuntu 10.04.1, but it probably isn't different than yours.

You need install tile:

  $ sudo apt-get install tk-tile

Note that Ruby will still use the ugly Tk 8.4. If you want it to use Tk
8.5 (but you don't have to), follow these steps:

  http://drx.rubyforge.org/ubuntu-new-tk.html

BTW, your program works on my system: I tried it with both Tk 8.4 and Tk
8.5 (I have a script that toggles between them).