I want to use Ruby 1.9.1 (Ubuntu 10.10) with Tk8.5 Tile, but this samle
code:

require 'tk'
require 'tkextlib/tile'

root = TkRoot.new { title "Ex1" }

Tk::Tile::Button.new(root) {
  text "Ok"
  command proc { print "Hello, World!"; exit }
  pack('side'=>'left', 'padx'=>10, 'pady'=>10)
}

Tk.mainloop()

fails with:
$ ruby tk_test.rb
/usr/lib/ruby/1.9.1/tkextlib/tile.rb:46:in `rescue in <top (required)>':
undefined method `__cannot_find_tk_package_for_widget_set__' for
Tk:Module (NoMethodError)
  from /usr/lib/ruby/1.9.1/tkextlib/tile.rb:31:in `<top (required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from tk_test.rb:2:in `<main>'


Googleing for "__cannot_find_tk_package_for_widget_set__" is one of
those rare moments when Google gives back only 1 hit.
Am I doing something wrong? I'm not a source code compiler type, I
installed everything from aptitude (Ruby 1.9.1, Tk8.4, Tk8.5, Tcl8.4,
Tcl8.5)

-- 
Posted via http://www.ruby-forum.com/.