On Fri, Apr 1, 2011 at 7:27 AM, Andrea Campi
<andrea.campi / zephirworks.com> wrote:
> we released today a new gem I think may be of general interest:
> https://rubygems.org/gems/ruby-perl
> https://github.com/zephirworks/ruby-perl

very nice. yet after installing, i get,

$ rperl
/usr/local/lib/ruby/gems/1.9.1/gems/ffi-1.0.7/lib/ffi/library.rb:75:in
`block in ffi_lib': Could not open library
'/usr/lib/perl/5.8/CORE/libperl.so':
/usr/lib/perl/5.8/CORE/libperl.so: cannot open shared object file: No
such file or directory (LoadError)
....

$ locate libperl.so
/usr/lib/libperl.so
/usr/lib/libperl.so.5.8
/usr/lib/libperl.so.5.8.8

$ lsb_release -a
LSB Version:	core-2.0-ia32:core-3.0-ia32:core-3.1-ia32:core-3.2-ia32:core-4=
.0-ia32:core-2.0-noarch:core-3.0-noarch:core-3.1-noarch:core-3.2-noarch:cor=
e-4.0-noarch:cxx-3.0-ia32:cxx-3.1-ia32:cxx-3.2-ia32:cxx-4.0-ia32:cxx-3.0-no=
arch:cxx-3.1-noarch:cxx-3.2-noarch:cxx-4.0-noarch:desktop-3.1-ia32:desktop-=
3.2-ia32:desktop-4.0-ia32:desktop-3.1-noarch:desktop-3.2-noarch:desktop-4.0=
-noarch:graphics-2.0-ia32:graphics-3.0-ia32:graphics-3.1-ia32:graphics-3.2-=
ia32:graphics-4.0-ia32:graphics-2.0-noarch:graphics-3.0-noarch:graphics-3.1=
-noarch:graphics-3.2-noarch:graphics-4.0-noarch:languages-3.2-ia32:language=
s-4.0-ia32:languages-3.2-noarch:languages-4.0-noarch:multimedia-3.2-ia32:mu=
ltimedia-4.0-ia32:multimedia-3.2-noarch:multimedia-4.0-noarch:printing-3.2-=
ia32:printing-4.0-ia32:printing-3.2-noarch:printing-4.0-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 8.04.4 LTS
Release:	8.04
Codename:	hardy

thanks for rperl.
best regards -botp