Am 31.03.2011 07:15, schrieb Une Bvue:
> Une Bvue <unbewusst.sein / fai.invalid> wrote:
> 
>> I wanted to gibe a try of wxRuby on Mac OS X SL (latest) after
>> installing wxRuby that way :
>>
>> imyt% sudo /opt/local/bin/gem1.9 install wxruby
>> Password:
>> Successfully installed wxruby-1.9.3-universal-darwin
>> 1 gem installed
>> Installing ri documentation for wxruby-1.9.3-universal-darwin...
>> Installing RDoc documentation for wxruby-1.9.3-universal-darwin...
>> imyt% 
>>
>> with the following testing script :
>>
>> #! /opt/local/bin/ruby1.9
>> # encoding: utf-8
>>
>> require 'rubygems'
>> require "wx"
>> include Wx 
>>
>> class MinimalApp < App
>>   def on_init
>>     Frame.new(nil, -1, "The Bare Minimum").show()
>>   end
>> end
>>
>> MinimalApp.new.main_loop
>>
>> i got :
>>
>> LoadError:
>> dlopen(/opt/local/lib/ruby1.9/gems/1.9.1/gems/wxruby-1.9.3-universal-dar
>> win/lib/wxruby2.bundle, 9): no suitable image found. Did find:
>> /opt/local/lib/ruby1.9/gems/1.9.1/gems/wxruby-1.9.3-universal-darwin/lib
>> /wxruby2.bundle: no matching architecture in universal wrapper -
>> /opt/local/lib/ruby1.9/gems/1.9.1/gems/wxruby-1.9.3-universal-darwin/lib
>> /wxruby2.bundle
>>
>> method require  in untitled document at line 29
>> method require  in untitled document at line 29
>> method <top (required)> in wx.rb at line 12
>> method require  in untitled document at line 33
>> method rescue in require        in untitled document at line 33
>> method require  in untitled document at line 29
>> method <main>   in first.rb at line 5
>>
>>
>> any idea ?
> 
> Adding my Ruby version :
> 
> imyt% which ruby1.9
> /opt/local/bin/ruby1.9
> imyt% ruby1.9 --version
> ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-darwin10]
> 
> 

You installed the version for Ruby 1.8. Do

# gem1.9 uninstall wxruby
# gem1.9 install wxruby-ruby19

Vale,
Marvin