hi austin -

  there's a gnome2 section of this forum, where it would be more 
appropriate to post this question.  i've had problems installing the 
latest gtk2 as well.  i currently use gtk 0.19.3 with ruby 1.8.7, both 
installed through my package manager, because i can't seem to get 
anything else to work - (see this post 
http://www.ruby-forum.com/topic/1291300#new , and others where i talk 
about my woes!)

  i'd suggest posting a more complete explanation of what's going on 
(i.e. what system you're on, what version of ruby, what version of gtk2, 
whether it's a gem install or you're building from source, etc.) on the 
gnome2 forum - you'll get more responses there than here....

  best of luck -

  -jk

-- 
Posted via http://www.ruby-forum.com/.