On Mar 16, 9:53     
> Hi,
>
> I use Ruby 1.9.2.180 and it crashes several time with same error message
> from event viewer. It comes and goes without any pattern and I have no
> specific re-produced steps. It seems to be related to "mshtml.dll". I
> checked event viewer, and it say:
>

I just attempted a clean 1.9.2-p180 installation, following the
installation instructions from watir website and using the examples
too:

http://watir.com/installation/
http://watir.com/examples/

C:\Users\Luis\Desktop>ruby --version
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

C:\Users\Luis\Desktop>gem --version
1.6.2

C:\Users\Luis\Desktop>gem list

*** LOCAL GEMS ***

builder (3.0.0)
commonwatir (1.8.0)
firewatir (1.8.0)
hoe (2.9.1)
nokogiri (1.4.4.1 x86-mingw32)
s4t-utils (1.0.4)
user-choices (1.1.6.1)
watir (1.8.0)
win32-api (1.4.8 x86-mingw32)
win32-process (0.6.5)
windows-api (0.4.0)
windows-pr (1.1.3)
xml-simple (1.0.14)

C:\Users\Luis\Desktop>type t.rb
require "rubygems"
require "watir"

browser = Watir::Browser.new
browser.goto("http://bit.ly/watir-example")

===

And worked without errors.

Something that is curious about your installation gems is win32-api.
In my case win32-api 1.4.8 was installed from binary form (1.4.8 x86-
mingw32) while in your case there is no platform binary mentioned.

For the sake of testing, can you remove the gem and install it again?

gem uninstall win32-api --all
gem install win32-api

--
Luis Lavena