2011/3/2 Robert Klemme <shortcutter / googlemail.com>:
> What Ruby versions are you using?    > between 1.8 and 1.9 in this area, namely that system, IO.popen etc.
> accept a list of strings which prevents passing the command to a
> shell.

$ ruby --version
ruby 1.9.0 (2008-10-04 revision 19669) [x86_64-linux] (Ubuntu)
ruby 1.9.0 (2008-06-20 revision 17482) [x86_64-linux] (Debian)
ruby 1.9.1p243 (2009-07-16 revision 24175) [x86_64-linux] (Gentoo)

-- 
Xavier NOELLE