On Jan 7, 5:18    򮮮
> On 7 January 2011 10:55, ghorner <gabriel.hor... / gmail.com> wrote:
>
>
>
>
>
>
>
>
>
> > On Jan 7, 3:37    򮮮
> >> On 7 January 2011 03:10, ghorner <gabriel.hor... / gmail.com> wrote:
>
> >> > On Jan 6, 4:19    򮮮
> >> >> On 6 January 2011 02:10, ghorner <gabriel.hor... / gmail.com> wrote:
>
> >> >> > On Jan 5, 10:55    򮮮
> >> >> >> Hello
>
> >> >> >> There is a serious issue with ripl.
>
> >> >> >> $ ripl
> >> >> >> Bond Error: Failed to load readline_line_buffer. Ensure that it exists
> >> >> >> and was built correctly.
>
> >> >> > For ruby < 1.9.2, you'll need to have readline installed. I'm
> >> >> > surprised your install reported no errors. Can you reinstall?
>
> >> >> I installed on another machine and do not get the error.
>
> >> > If your install is building the readline_line_buffer extension
> >> > correctly, then the problem must be you can't find it. What does the
> >> > following command give you?
>
> >> > find $(dirname $(gem which bond)) | grep readline_line_buffer
>
> >> > You should get the path of the extension. Try requiring that path
> >> > after requiring ripl.
>
> >> Apparently bond requires readline development files but does not
> >> report an error when they are not present.
>
> > It reports a missing readline.h:
> >https://github.com/cldwalker/bond/blob/master/ext/readline_line_buffe...
> > What development files are you missing?
>
> > Did you see an extension built with the above command? If not,
> > debian's quirks with executables make it suspect for this as well.
>
> I am running Debian so I need the libreadline5-dev package to get the
> libreadline.so and readline headers.
>
> The gem installs both with and without this package installed (the
> versioned readline shared library is always installed as dependecy of
> many packages).
>
> When the gem is installed without the readline development package
> present it installs successfully without any error reported but the
> extension fails to load when used by ripl.
>
> <no error>
>
> # aptitude remove libreadline5-dev
> The following packages will be REMOVED:
> libreadline5-dev
> 0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> Need to get 0 B of archives. After unpacking 811 kB will be freed.
> (Reading database ... 210501 files and directories currently installed.)
> Removing libreadline5-dev ...
> Processing triggers for install-info ...
>
> OptiPlex960:/home/hramrach# gem pristine bond
> Restoring gem(s) to pristine condition...
> Building native extensions.   宮
> Restored bond-0.3.4
>
> <still no error>
>
> # gem uninstall bond
>
> You have requested to uninstall the gem:
> bond-0.3.4
> ripl-0.3.0 depends on [bond (~> 0.3.4)]
> If you remove this gems, one or more dependencies will not be met.
> Continue with Uninstall? [Yn]
> Successfully uninstalled bond-0.3.4
> OptiPlex960:/home/hramrach# gem install bond
> Building native extensions.   宮
> Successfully installed bond-0.3.5
> 1 gem installed
> Installing ri documentation for bond-0.3.5...
> Installing RDoc documentation for bond-0.3.5...
>
> <error loading readline_line_buffer>
>
> # aptitude install libreadline5-dev
> The following NEW packages will be installed:
> libreadline5-dev
> 0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0 B/243 kB of archives. After unpacking 811 kB will be used.
> Selecting previously deselected package libreadline5-dev.
> (Reading database ... 210474 files and directories currently installed.)
> Unpacking libreadline5-dev (from .../libreadline5-dev_5.2-7_amd64.deb) ...
> Processing triggers for install-info ...
> Setting up libreadline5-dev (5.2-7) ...
> Ignoring install-info called from maintainer script
> The package libreadline5-dev should be rebuilt with new debhelper to
> get trigger support
> Ignoring install-info called from maintainer script
> The package libreadline5-dev should be rebuilt with new debhelper to
> get trigger support
>
> # gem pristine bond
> Restoring gem(s) to pristine condition...
> Building native extensions.   宮
> Restored bond-0.3.5
>
> < no error again >

Unfortunately, none of this helps but to illustrate what you've
already said. If 5.2 is the readline version you're using, you should
consider upgrading. I'm on readline 6.1 and have only used bond with
readline >= 5.6.

What would help is to know what you get back from `find $(dirname $
(gem which bond)) | grep readline_line_buffer` . Your response didn't
mention what you got back. If you did get back a file, then try the
following install with appropriate paths for your readline:

     gem install bond -- --with-readline-lib=/path/to/your/lib --with-
readline-include=/path/to/your/include

If you didn't get back a file, then I probably can't help because
debian is possibly placing it outside the gem's directory.

Gabriel