On 01/07/2011 02:28 PM, Roman Mandeleil wrote:
> Found it , I should include rubygems in the file also, on linux on 
> window it is working without it.

You may be running different versions of Ruby on Windows and Linux.
Ruby 1.9 includes rubygems by default so you don't need to go out of
your way to require it in your scripts or set RUBYOPT to do it for you.
 Ruby 1.8 requires a bit of effort on your part though. :-)

Given what you're reporting, you're probably using Ruby 1.9 on Windows
and Ruby 1.8 on Linux.  You can check this by running "ruby -v" on both
systems to see what version is reported.

-Jeremy