Hi.
    when I try to do script/server I am getting this error.
Rails 2.3.8 application starting on http://0.0.0.0:3000
/opt/local/lib/ruby/gems/1.8/gems/mail-2.2.13/lib/mail/core_extensions/smtp.rb:7:in
`remove_method': method `tlsconnect' not defined in Net::SMTP
(NameError)
  from
/opt/local/lib/ruby/gems/1.8/gems/mail-2.2.13/lib/mail/core_extensions/smtp.rb:7
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`gem_original_require'
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from /opt/local/lib/ruby/gems/1.8/gems/mail-2.2.13/lib/mail.rb:36
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`gem_original_require'
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/gem_dependency.rb:215:in
`load'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`load_gems'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`each'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`load_gems'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:164:in
`process'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in
`send'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in
`run'
  from /Users/awijeet/railsaps/loc/config/environment.rb:5
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`gem_original_require'
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
  from
/opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/commands/server.rb:84
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`gem_original_require'
  from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
`require'
  from script/server:3


Can any one help me please to solve the issue.

Thanks Avijit

-- 
Posted via http://www.ruby-forum.com/.