rubygems version 1.4.0 has been released!

* <http://rubygems.org>
* <http://docs.rubygems.org>
* <http://help.rubygems.org>
* <http://github.com/rubygems>

RubyGems is a package management framework for Ruby.

This gem is an update for the RubyGems software. You must have an
installation of RubyGems before this update can be applied.

See Gem for information on RubyGems (or `ri Gem`)

To upgrade to the latest RubyGems, run:

  $ gem update --system  # you might need to be an administrator or root

########################################################################

NOTE: Ruby 1.9 ships with rubygems and contains a very buggy
"gem-prelude". It is a gem loading system that can interfere with
updating rubygems itself. We do NOT recommend you update to rubygems
1.4 if you're running ruby 1.9.x until we get that sorted out in a
future ruby release.

If you absolutely hate kittens and you _must_ upgrade, you're going to
have to do something really hokey like:

% alias ruby19="ruby19 --disable-gems"
% alias gem19="ruby19 --disable-gems -S gem"

Even deleting the stock rubygems in 1.9 doesn't fix this situation.

########################################################################

If you don't have any RubyGems install, there is still the pre-gem approach to
getting software, doing it manually:

1. Download from: https://rubygems.org/pages/download
2. Unpack into a directory and cd there
3. Install with: ruby setup.rb  # you may need admin/root privilege

For more details and other options, see:

  ruby setup.rb --help

Changes:

### 1.4.0 / 2010-12-31

NOTE: In order to better maintain rubygems and to get it in sync with
the world (eg, 1.9's 1.3.7 is different from our 1.3.7), rubygems is
switching to a 4-6 week release schedule. This release is the
precursor to that process and as such may be a bit on the wild side!
You have been warned!

NOTE: We've switched to git/github. See README.rdoc for details.

New features:

* Added --launch option to `gem server`. (gthiesfeld)
* Added fuzzy name matching on install failures. (gstark/presidentbeef)
* Allow searching w/ file extensions: gem which fileutils.rb
* Progress indicator during download (Ryan Melton)
* Speed up Gem::Version#<=> by 2-3x in common cases. (raggi)
* --source is now additive with your current sources.
  Use --clear-sources first to maintain previous behavior.

Bug fixes:

* Dependency "~>"s now respect lower-bound prerelease versions.
* Ensure the gem directories exist on download.
* Expand Windows user home candidates for Ruby 1.8. Bug #28371 & #28494
* Fix find_files to order by version.
* Fix ivar typo. [Josh Peek]
* Normalized requires and made many of them lazy.
  Do not depend on rubygems to require stdlib stuff for you. (raggi/tmm1)
* Treat 1.0.a10 like 1.0.a.10 for sorting, etc. Fixes #27903. (dchelimsky)