On Mon, Dec 20, 2010 at 9:20 PM, Aaron Allison <allisonaaronb / gmail.com> wrote:
> I am trying to update my mac to the latest ruby.
>
> I follow the instructions on Hivelogic
> http://hivelogic.com/articles/ruby-rails-leopard. I compiled Ruby from
> source but when I do ruby -v I get ruby 1.8.7 (2009-06-12 patchlevel
> 174) [universal-darwin10.0]. Not the latest. I didn't get any errors
> when I compiled. Anybody else run into this problem?

Try:
/usr/local/bin/ruby -v

Also, take a look at Homebrew and RVM.