I installed ImageMagick from source like was insturcted at:
http://rmagick.rubyforge.org/install-faq.html

Then I installed RMagick which went well (it didn't succeed earlier when
I installed ImageMagick with apt-get). But then when I tried to run
"ruby RMagickIntegration.rb" I got following error messages:

---------------------------------

/var/lib/gems/1.8/gems/rmagick-2.13.1/lib/RMagick2.so:
libMagickCore.so.4: cannot open shared object file: No such file or
directory - /var/lib/gems/1.8/gems/rmagick-2.13.1/lib/RMagick2.so
(LoadError)
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in `require'
  from /var/lib/gems/1.8/gems/rmagick-2.13.1/lib/RMagick.rb:11
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:36:in `require'
  from RMagickIntegration.rb:16

----------------------------------

There was written something about similar subject in that install-faq
link. I should add some text to my startup file, but I don't know where
it is located. My system is Ubuntu 10.10.

-- 
Posted via http://www.ruby-forum.com/.