Thanks Phillip, but what I am confused now is about how I require one 
gem after the other? how do I control which gems are loaded?

right now if I take a look at my program's Gemfile, it's just:

source 'http://rubygems.org'

gem 'rails', '3.0.3'
gem 'sqlite3-ruby', :require => 'sqlite3'
gem 'asin'

And thanks again for all the help.

And if I do:


> gem list

*** LOCAL GEMS ***

abstract (1.0.0)
actionmailer (3.0.3, 2.1.2)
actionpack (3.0.3, 2.1.2)
activemodel (3.0.3)
activerecord (3.0.3, 2.1.2)
activeresource (3.0.3, 2.1.2)
activesupport (3.0.3, 2.3.9, 2.1.2)
arel (2.0.6)
asin (0.0.8)
bcrypt-ruby (2.1.2)
bson (1.1.4)
bson_ext (1.1.4)
builder (3.0.0, 2.1.2)
bundler (1.0.7)
capistrano (2.5.19, 2.5.0)
cgi_multipart_eof_fix (2.5.0)
commonwatir (1.6.7, 1.6.2)
configuration (1.2.0)
crack (0.1.8)
curb (0.7.8)
daemons (1.1.0, 1.0.10)
devise (1.1.5)
diff-lcs (1.1.2)
erubis (2.6.6)
fastthread (1.0.7, 1.0.1)
firewatir (1.6.7, 1.6.2)
gem_plugin (0.2.3)
hashie (0.4.0, 0.2.2)
heroku (1.14.9, 1.14.8)
highline (1.6.1, 1.5.0)
hoe (2.8.0, 2.7.0, 1.8.2)
httparty (0.6.1)
httpclient (2.1.5.2)
i18n (0.5.0)
imdb_party (0.3.0)
json_pure (1.4.6)
launchy (0.3.7)
mail (2.2.12)
mime-types (1.16)
mongo (1.1.4)
mongoid (2.0.0.beta.20)
mongrel (1.1.5)
mysql (2.8.1, 2.7)
mysql2 (0.2.6)
net-scp (1.0.4, 1.0.1)
net-sftp (2.0.5, 2.0.1)
net-ssh (2.0.23, 2.0.4)
net-ssh-gateway (1.0.1, 1.0.0)
nokogiri (1.4.4)
ParseTree (3.0.6, 3.0.2, 2.1.1)
polyglot (0.3.1)
rack (1.2.1)
rack-mount (0.6.13)
rack-test (0.5.6)
rails (3.0.3, 2.1.2)
railties (3.0.3)
rake (0.8.7, 0.8.3)
rest-client (1.6.1)
rspec (2.3.0, 2.1.0, 1.1.11)
rspec-core (2.3.0, 2.1.0)
rspec-expectations (2.3.0, 2.1.0)
rspec-mocks (2.3.0, 2.1.0)
ruby2ruby (1.2.5, 1.2.1, 1.1.8)
ruby_parser (2.0.5)
rubyforge (2.0.4, 1.0.1)
rubygems-update (1.3.7)
RubyInline (3.8.6, 3.8.1)
rvm (1.1.5)
s4t-utils (1.0.4)
sake (1.0.15)
sexp_processor (3.0.5)
simple_form (1.3.0)
sqlite3-ruby (1.2.4)
sucker (1.1.3)
termios (0.9.4)
thor (0.14.6)
treetop (1.4.9)
tzinfo (0.3.23)
user-choices (1.1.6.1, 1.1.6)
warden (1.0.3)
will_paginate (3.0.pre2)
xml-simple (1.0.12, 1.0.11)
yayimdbs (0.1.9)
ZenTest (4.4.2, 4.4.0, 3.11.0)

-- 
Posted via http://www.ruby-forum.com/.