On Dec 12, 2010, at 9:20 PM, Guru I. wrote:

> I have just started learning ruby and Im using ruby 1.9.2p0 =
(2010-08-18
> revision 29036) [x86_64-darwin10.5.0].

> =
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/cs=
v.rb:312:in
> `open_reader'
>  from

Something has gotten confused with your Ruby install, because you =
mention version 1.9, but the code is trying to load a 1.8 library.

RVM is probably the best way to manage your Ruby installs on Mac OS X, =
so I recommend you try that:

  http://rvm.beginrescueend.com/

Hope that helps.

James Edward Gray II