On Fri, Dec 10, 2010 at 11:39 AM, A. Mcbomb <atomicmcbomb / gmail.com> wrote:
> That definately helped, Jesus....thanks.
>
> Here is what I get now when I run the test script:
>
> [server01][/usr/bin]$ ./test.rb
> HI.  ﲮ   > has
> plenty of bugs.   ̯ > you
> upgrade your version of libxml2 and re-install nokogiri.  
> using
> libxml2 version 2.6.16, but don't like this warning, please define the
> constant
> I_KNOW_I_AM_USING_AN_OLD_AND_BUGGY_VERSION_OF_LIBXML2 before requring
> nokogiri.
>
>
> This sounds like I should upgrade....would you recommend just simply
> replacing the one file (libxml2) and then reinstall the gem or are there
> more files that I should replace such as libxslt as well?
>
> thank you so much for helping me to get this going Jesus!

What OS (and version are you on?). I have a pretty old version of
Ubuntu (8.10) and have libxml2.so.2.6.32.
To correctly upgrade a library, please use your OS facilities (apt,
yum or whatever).

Jesus.