hey, so i tried doing what you advised.. but once again i get errors 
with the ncurses library :D

I could not do the first line u told me (sudo apt-get install 
build-essentials)  and the software centre had nothing called compiler 
toolchain.
i did however manage to install ncurses-dev.
Sudo gem install didndt work, soo i did sudo apt-get install rubygems 
and that worked.
then i did the gem install and i get this error:

nikita@ubuntu:~$ sudo gem install ncurses
Building native extensions.  This could take a while...
ERROR:  Error installing ncurses:
  ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
extconf.rb:22:in `require': no such file to load -- mkmf (LoadError)
  from extconf.rb:22


Gem files will remain installed in /var/lib/gems/1.8/gems/ncurses-0.9.1 
for inspection.
Results logged to /var/lib/gems/1.8/gems/ncurses-0.9.1/gem_make.out


contents of gem_make.out file :
/usr/bin/ruby1.8 extconf.rb
extconf.rb:22:in `require': no such file to load -- mkmf (LoadError)
  from extconf.rb:22


What i was thinking is this. it keeps writing ruby 1.8, and i got the 
latest ruby 1.9.x  (atleast i think so). Maybe this is why ncurses isnt 
working?

-- 
Posted via http://www.ruby-forum.com/.