Yes, I would recommend upgrading to 1.5.6. If you are using OpenSSL,
make sure you're on the latest jruby-openssl gem as well.

Some of the issues you mention have been fixed on the 1.5 branch, and
are in 1.5.6. As for JRuby 1.6, we hope to have at least RCs out this
month and a final version soon after. If you have cycles to test a
development build of 1.6, you can go to http://ci.jruby.org/snapshots
to get one.

- Charlie

On Fri, Nov 19, 2010 at 1:02 AM, Prachi Tripathi
<prachi.tripathi / tcs.com> wrote:
> Hi,
>
> Thanks for ur prompt reply.
>
> Jruby 1.6 is still in dev right? When will it be released for production
> use? Our app has been deployed in production. So this is a production
> issue. So what do u recommend, upgrading to 1.5.5?
>
> --
> Posted via http://www.ruby-forum.com/.
>
>