I've just had the same problem trying to upgrade rubygems from 1.2.0 to 
1.3.7.

Setp-1)
So I just downloaded rubygems-update-1.3.7.gem from 
http://rubyforge.org/frs/?group_id=126

Setp-2)
gem install rubygems-update-1.3.7.gem

Setp-3)
update_rubygems


and it work for me.

-- 
Posted via http://www.ruby-forum.com/.