-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 15.11.2010 10:37, schrieb Dd Dd:
> tk (LoadError)
>         from <internal:lib/rubygems/custom_require>:29:in `require'
>         from scope.rb:1:in `<main>'
> 

Your Ruby installation simply misses the Tk library. The RubyInstaller
team doesn't provide it. If you have the RubyInstaller Team's Devkit
installed, you may try to install Tk by

gem install tk_as_gem

And please don't save your Ruby scripts in Ruby's bin/ directory!

> try to download ruby from this site than it might work
>
> http://www.ruby-lang.org/en/

No, it won't. He's on Windows and likely doesn't have a C compiler. And
the binaries provided at ruby-lang.org are compiled with the Microsoft
Visual C/C++ compiler, which isn't the recommanded Ruby on Windows
anymore (the MinGW-compiled one provided by the RubyInstaller team at
http://rubyinstaller.org now is it).

Vale,
Marvin
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJM4QRaAAoJEGrS0YjAWTKVWUQH/39fjXPf/Z7T76BiYmsdzcIF
cK/9z1QbVeZM1bFhJu0k+vZiszyCBr2Yz8m5K+hUp5vNZFnpLBTxkVYQ1Og5ldy9
D3Ldwv7mdmpSUaW1r0mKCSTyplgv0zcSXZMHOHhv8HnAvjcdh0GypFK0ysMI/LGq
mcVzWtq9A8ahkkT4RkbMNz6aUV4PF+EylvtHOYXATeGEtYnVuqKUOb2H0Cc1vdXK
i/jMDKBGvln0Fd/3X3m+QUftqMlpefrxPJFEMjQKcYDk7MXR/nIbhhI3Y1L4EgDe
2DwuolWXdDpQPt3e8ELzVJN23odyDnZCKnM1T/Op9LCgUfSX4vqyxqDlA4hfKUE=
=OyMj
-----END PGP SIGNATURE-----