What can I download and install with emacs-23 and above so that emacs
will properly recognize ruby files for what they are and support their
development?  That will make my Linux boxes much happier if support is
available.