In that case Watir will raise an exception because it strictly loads
2.3.9. There is plan to remove active-support dependency completely in
FireWatir

Jarmo

On Oct 23, 5:58     
> On Oct 23, 11:37  ﮮ 
>
>
>
>
>
> > i am using active record in my program and cannot understand what this
> > error means.
>
> > require 'watir'
>
> > include Watir
> > require 'active_record'
>
> > ActiveRecord::Base.establish_connection(
> > :adapter => "mysql",
> > :host => "127.0.0.1",
> > #:host => "sun",
> > :database => "Trader",
> > :username => "root",
> > :password => "password"
> > )
> > class Rawdata < ActiveRecord::Base
> >  
>
> > end
>
> > E:\TradingTools\trader\app\helpers>GrabMBTTrades.rb
> > C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:233:in `activate': can't
> > activate
> > activesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"], already
> > activated a
> > ctivesupport-2.3.9 for ["firewatir-1.6.6", "watir-1.6.6"]
> > (Gem::LoadError)
>
> It is telling you that firewater and watir required activesupport
> 2.3.9, so if you want ActiveSupport 3.0.1 you need to require it first
> (before requiring watir)
>
> --
> Luis Lavena