I am trying to get ruby set up on a gumstix overo running angstrom linux
with a gnome desktop. I keep getting an error during make that I am sure
is a basic beginner issue that I seem to not be able to sort out. It
always gives me this error:
gcc -O3 -ggdb -Wextra -Wno-unused-parameter -Wno-parentheses
-Wpointer-arith -Wwrite-strings -Wno-missing-field-initializers
-Wno-long-long  -fPIC -I. -I.ext/include/armv7l-linux-eabi -I./include
-I. -DRUBY_EXPORT   -o enum.o -c enum.c
gcc -O3 -ggdb -Wextra -Wno-unused-parameter -Wno-parentheses
-Wpointer-arith -Wwrite-strings -Wno-missing-field-initializers
-Wno-long-long  -fPIC -I. -I.ext/include/armv7l-linux-eabi -I./include
-I. -DRUBY_EXPORT   -o enumerator.o -c enumerator.c
echo executable host ruby is required.  use --with-baseruby option.;
false ./tool/generic_erb.rb -c -o known_errors.inc
./template/known_errors.inc.tmpl ./defs/known_errors.def
executable host ruby is required. use --with-baseruby option.
make: *** [known_errors.inc] Error 1


Here is how i did the configure:
./configure --prefix=/opt/metasploit3 --enable-pthread --enable-shared
I have also tried with just ./configure and still get the same problem
as above. Configuring either way goes through fine its in the make where
it fails.

I have tried during configure and make to add the --with-baseruby and
neither gives me a completed make to install. What am I missing here?
Thanks for any help and please feel free to ask me anymore info that I
may have forgotten. Also I tried searching online and dont see the
--with-baseruby option anywhere
-- 
Posted via http://www.ruby-forum.com/.