At 2010-09-17 03:26AM, "Brian Candler" wrote:
[...]
>  Before you rebuild, I suggest you also check you have the openssl-devel 
>  package installed, otherwise you won't be able to use things like 
>  Net::HTTPS.

In my (brief) experience (building Ruby in Cygwin), in addition to the
openssl devel package, you'll need to:

    cd [ruby_src]/ext/openssl
    ruby extconf.rb
    make
    make install


-- 
Glenn Jackman
    Write a wise saying and your name will live forever. -- Anonymous