Luis Lavena wrote:
> On Sep 15, 2:17pm, Ed Howland <ed.howl... / gmail.com> wrote:
>> Is the mingw component now builtin to RubyInstaller?
> The compiler environment (DevKit) is not bundled with the installer,
> specifically because not all users will require to compile extensions.

Also, the DevKit is the same for MRI, YARV and (in future) JRuby. It
doesn't make sense to either install, release or maintain separate
copies of the DevKit. Not because of the waste of disk space or
download bandwidth, but for the same software engineering reasons that
you *always* try to eliminate code duplication.

If you install, say, both JRuby and MRI, you still need only one copy
of the DevKit. This wouldn't be possible, if it was built into the
respective installers.

jwm