Each time i launch a script using Nokogiri i get :
WARNING: Nokogiri was built against LibXML version 2.7.7, but has
dynamically loaded 2.7.3

despit this warning the script works as expected.

what is the best way to get right libxml ?

my libxml is installed using MacPorts Ruby 1.9 too.
Nokogiri is installed rubygems of the ruby 1.9 installed by macports.
-- 
Pour ceux qui vont chercher midi quatorze heures, 
  la minute de vitrisque de se faire longtemps attendre.  
  (Pierre Dac)