On Aug 26, 12:41=A0pm, Tim Ss <advancedtechnolog... / gmail.com> wrote:
> I am just learning Ruby and have become somewhat frustrated on this
> issue.
>
> I am trying to install Redcloth and I keep getting an error back
>
> C:\>gem install RedCloth
> Building native extensions. =A0This could take a while...
> ERROR: =A0Error installing RedCloth:
> =A0 =A0 =A0 =A0 ERROR: Failed to build gem native extension.
>
> C:/Ruby186/bin/ruby.exe extconf.rb
> creating Makefile
>
> make
> 'make' is not recognized as an internal or external command,
> operable program or batch file.
>

You need a compiler.

> I installed Ruby 1.8.6-p398 and downloaded gems 1.3.7 and installed
> that.

If you installed Ruby 1.8.6 from RubyInstaller, you don't need to
download RubyGems, it is already part of the package.

Please download the DevKit and follow the installation instructions
from our wiki:

http://rubyinstaller.org/downloads
http://wiki.github.com/oneclick/rubyinstaller/development-kit

I would recommend you also install Ruby 1.8.7 instead of 1.8.6, as
that version has been kept for compatibility reasons while 1.8.7 is
receiving more support form both Ruby developers and RubyInstaller
team.

HTH,
--
Luis Lavena