Should I write
	var.kind_of?( NilClass )
or simply
	var == nil
?

I have the feeling that kind_of?(NilClass) is more "proper"/"clean"
but then again it decreases the readability and might not even be
necessary.

Are there any situations where it makes sense to subclass NilClass?


Regards,
  Philipp