Confirmed, this happens on the version of gem installed with OS X 10.5

Upgrade it by following these intructions
http://docs.rubygems.org/read/chapter/3