On Jul 16, 4:12=A0am, Jon Rosen <j... / openstage.org> wrote:

>  =A0I am
> running Ruby 1.9.1 and Mysql 2.8.1 which are the latest and greatest as
> far as I know.
>

Just a small comment:  Your script works for my local environment
without problems:

ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-darwin10]
mysql5  Ver 14.14 Distrib 5.1.47, for apple-darwin10.3.0 (i386) using
readline 6.1

Patrick