On Jun 30, 10:57=A0am, Roger Pack <rogerpack2... / gmail.com> wrote:
> > * RubyGems now has platform support for IronRuby. =A0Patch #27951 by Wi=
ll
> > Green.
>
> Hmm. =A0Perhaps it could use a bit more IR love?
>
> C:\dev\digitalarchive_trunk>igem update --system
> Updating RubyGems
> Updating rubygems-update
> Successfully installed rubygems-update-1.3.7
> Updating RubyGems to 1.3.7
> Installing RubyGems 1.3.7
> ERROR: =A0While executing gem ... (Gem::Exception)
> =A0 =A0 [BUG] invalid exec_format "ir", no %s
> RubyGems system software updated
>
> C:\dev\ruby\downloads\rubygems-1.3.7>ir setup.rb
> ERROR: =A0While executing gem ... (Gem::Exception)
> =A0 =A0 [BUG] invalid exec_format "ir", no %s

No, you can't update IronRuby with gem update --system

Use a IronRuby RubyGems 1.3.7 powered version, which is latest one.

--
Luis Lavena