James Edward Gray II wrote:
> On Jun 26, 2010, at 5:36 AM, R.. Kumar wrote:
> 
>> /opt/local/lib/ruby1.9/?
> 
> It looks like this is a difference in Ruby 1.9 that isn't related to 
> HighLine:
> 
> $ cat eof_change.rb
> puts "Enter multiple lines:"
> p $stdin.read
> 
> puts "Question?"
> p $stdin.gets
> 

Yup.
 I ran your snippet with 1.9.1 and with the stock /usr/bin/ruby (ruby 
1.8.7 (2009-06-08 patchlevel 173) [universal-darwin10.0]) which I never 
use, and I get the same results. 1.9.1 fails, 1.8.7 works :-(

Do you know who to forward this issue to ? Could you possibly inform the 
correct person -- I am not familiar with the process.

I have an unrelated question. Some months ago i checked the RVM site and 
was frightened off -- it said DO NOT install rvm using gem, and it gave 
some complicated procedure.
Did you install the rvm gem ? If not, is there a link for the best 
procedure to install. I am now a bit weary of custom installs, it take 
too much out of me to keep maintaining them. Thanks.
-- 
Posted via http://www.ruby-forum.com/.