On Jun 12, 2010, at 06:00 , Emmanuel Mercado wrote:

> hi,
> 
> below is the setup i have:
> Mac OS X Snow Leopard
> running ruby 1.8.7 installed using hivelogic procedure
> 
> installed libxml2 and libxslt from source
> installed nokogiri 1.4.2 using sudo gems
> [...]
> 
> why am i getting the following message when i issue 'require nokogiri'
> on irb?
> 
> EMercados-MacBook-Pro:~ ermercado$ irb
> irb(main):001:0> require 'nokogiri'
> LoadError:
> dlopen(/usr/local/lib/ruby/gems/1.8/gems/nokogiri-1.4.2/lib/nokogiri/nokogiri.bundle,

If you're on snow leopard, then why not skip the hivelogic crap and use stock everything? It Just Works(tm).

If not, then try otool to figure out what went wrong:

509 % otool -L /Library/Ruby/Gems/1.8/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.bundle
/Library/Ruby/Gems/1.8/gems/nokogiri-1.4.1/lib/nokogiri/nokogiri.bundle:
	/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/libruby.1.dylib (compatibility version 1.8.0, current version 1.8.7)
	/usr/lib/libexslt.0.dylib (compatibility version 9.0.0, current version 9.13.0)
	/usr/lib/libxslt.1.dylib (compatibility version 3.0.0, current version 3.24.0)
	/usr/lib/libxml2.2.dylib (compatibility version 10.0.0, current version 10.3.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.0.0)