hi,

below is the setup i have:
Mac OS X Snow Leopard
running ruby 1.8.7 installed using hivelogic procedure

installed libxml2 and libxslt from source
installed nokogiri 1.4.2 using sudo gems


EMercados-MacBook-Pro:~ ermercado$ gem list

*** LOCAL GEMS ***

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
cgi_multipart_eof_fix (2.5.0)
cheat (1.2.1)
daemons (1.0.10)
eventmachine (0.12.10)
fastthread (1.0.7)
gem_plugin (0.2.3)
mongrel (1.1.5)
mysql (2.8.1)
nokogiri (1.4.2, 1.3.3)
rack (1.0.1)
rails (2.3.5)
rake (0.8.7)
rspec (1.2.9)
rubygems-update (1.3.6)
sqlite3-ruby (1.2.5)
thin (1.2.4)


why am i getting the following message when i issue 'require nokogiri'
on irb?

EMercados-MacBook-Pro:~ ermercado$ irb
irb(main):001:0> require 'nokogiri'
LoadError:
dlopen(/usr/local/lib/ruby/gems/1.8/gems/nokogiri-1.4.2/lib/nokogiri/nokogiri.bundle,
9): no suitable image found.  Did find:
  /usr/local/lib/ruby/gems/1.8/gems/nokogiri-1.4.2/lib/nokogiri/nokogiri.bundle:
mach-o, but wrong architecture -
/usr/local/lib/ruby/gems/1.8/gems/nokogiri-1.4.2/lib/nokogiri/nokogiri.bundle
  from
/usr/local/lib/ruby/gems/1.8/gems/nokogiri-1.4.2/lib/nokogiri/nokogiri.bundle
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/local/lib/ruby/gems/1.8/gems/nokogiri-1.4.2/lib/nokogiri.rb:13
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
  from (irb):1


even after issuing the below command:

EMercados-MacBook-Pro:~ ermercado$ export RUBYOPT="rubygems"

thanks very much for your help
manny
-- 
Posted via http://www.ruby-forum.com/.