Robert Klemme wrote:
> puts (0...5).to_a

Pointless golf of the day:

puts(*0...5)

But this is even farther from the original point, which is why not have 
a more compact notation for when you need to pass more than one block to 
a method.