Make sure you installed wxruby for 1.9 instead of 1.8 "run gem install
wxruby-ruby19"

remove the require for rubygems because you are using 1.9.1
change the require 'wxruby' to require 'wx'


--------------------------------------------------------------
Allan Davis
Member of NetBeans Dream Team
http://wiki.netbeans.org/NetBeansDreamTeam
Lead Developer, nbPython
http://wiki.netbeans.org/Python
http://codesnakes.blogspot.com (my blog)
Co-Chair, CajunJUG
http://www.cajunjug.org


On Sun, May 9, 2010 at 7:06 PM, Ivo Roupa <iroupa / gmail.com> wrote:

> Hi all
>
> I don't understand what's going wrong when I try to use the wxruby2...
>
> I followed the http://wxruby.rubyforge.org/wiki/wiki.pl instructions but
> I always get this error when I run the following code:
>
>
>  require "wxruby"
>  require "rubygems"
>  include Wx
>
>
>  class MinimalApp < App
>    def on_init
>         Frame.new(nil, -1, "The Bare Minimum").show()
>    end
>  end
>
>
>  MinimalApp.new.main_loop
>
>
>  C:/Documentos/Ruby Scripts/form_01/lib/main.rb:1:in `require': no such
> file
> to load -- wxruby (LoadError)
>        from C:/Documentos/Ruby Scripts/form_01/lib/main.rb:1:in
> `<main>'
>
>
> I have ruby 1.9.1,Windows XP sp3 and I'm using NetBeans 6.8.
>
> Thanks in advanced for any help
>
> Ivo Roupa
> --
> Posted via http://www.ruby-forum.com/.
>
>