I found some similar problems here on SO, but none seem to match my case
(sorry if I overlooked). Here's my problem: I installed oauth-plugin gem
to ruby gems dir, but trying to use it in rails app tells me that it's
not being found. Here's the output of relevant commands:

Instalation

    % s gem install oauth-plugin
    Successfully installed oauth-plugin-0.3.14
    1 gem installed
    Installing ri documentation for oauth-plugin-0.3.14...
    Installing RDoc documentation for oauth-plugin-0.3.14...

`gem which oauth-plugin` output:

    % gem which oauth-plugin
    /usr/lib/ruby/gems/1.8/gems/oauth-plugin-0.3.14/lib/oauth-plugin.rb

`gem env` output:

    % gem env
    RubyGems Environment:
      - RUBYGEMS VERSION: 1.3.6
      - RUBY VERSION: 1.8.7 (2009-12-24 patchlevel 248)
[i686-darwin10.2.0]
      - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
      - RUBY EXECUTABLE: /usr/bin/ruby
      - EXECUTABLE DIRECTORY: /usr/bin
      - RUBYGEMS PLATFORMS:
        - ruby
        - x86-darwin-10
      - GEM PATHS:
         - /usr/lib/ruby/gems/1.8
         - /Users/eimantas/.gem/ruby/1.8
      - GEM CONFIGURATION:
         - :update_sources => true
         - :verbose => true
         - :benchmark => false
         - :backtrace => true
         - :bulk_threshold => 1000
         - :gem => ["--no-ri", "--no-rdoc"]
         - :sources => ["http://gems.ruby.lt/", "http://rubygems.org/"]
      - REMOTE SOURCES:
         - http://gems.ruby.lt/
         - http://rubygems.org/

Doing `ls -l /usr/lib/ruby` shows this:

    % ls -l /usr/lib/ruby
    lrwxr-xr-x  1 root  wheel  76 Aug 14  2009 /usr/lib/ruby ->
../../System/Library/Frameworks/Ruby.framework/Versions/Current/usr/lib/ruby

And the gem in question is in intended location. This is not a single
gem that is not being found by rubygems (although it's located where it
should be). Any guidance towards the solution is much appreciated.
-- 
Posted via http://www.ruby-forum.com/.